Site availability issues
Incident Report for Upsales
Resolved
This incident has been resolved.
Posted Jun 15, 2021 - 16:45 CEST
Identified
Some customers may currently be experiencing site availability issues. We’re currently working to resolve this issue.
Posted Jun 15, 2021 - 16:34 CEST
This incident affected: Upsales App, System components (File service), and Integrations (Other integrations).