Upsales Partial Down
Incident Report for Upsales
Resolved
This incident has been resolved.
Posted Sep 22, 2021 - 13:30 CEST
Identified
We are aware of reports that Upsales is partially down for some customers. Our operations engineers are looking into it. Sorry for the inconvenience – we’ll have a solution for this soon!
Posted Sep 22, 2021 - 13:15 CEST
This incident affected: Upsales App.