Performance degradation

Incident Report for Upsales

Resolved

This issue has been resolved and Upsales performance has returned to normal. We identified and fixed the underlying cause, and we’re continuing to monitor the system.

If you’re still experiencing slowness, please contact support.
Posted Feb 02, 2026 - 15:28 CET

Investigating

Some users may experience slow load times and delayed actions within Upsales.
Posted Feb 02, 2026 - 14:50 CET
This incident affected: Upsales App.