Outlook calendar sync temporarily affected

Incident Report for Upsales

Resolved

This issue has been resolved, and syncing between Upsales and Outlook is now working as expected. We’ll keep monitoring the fix to make sure it stays stable.
Posted Nov 10, 2025 - 15:59 CET

Investigating

Some users may notice that meetings created in Upsales are not syncing to their Outlook calendars.

We’ve identified the issue and are working on a fix.
Until it’s resolved, we recommend creating new meetings directly in your Outlook calendar. Once the issue is fixed, meetings will sync back to Upsales as normal.
Posted Nov 07, 2025 - 09:59 CET
This incident affected: Integrations (Office 365 calendar sync).