Issue with Outlook calendar integration

Incident Report for Upsales

Resolved

This incident has been resolved.
Posted Apr 16, 2026 - 08:37 CEST

Monitoring

A fix has been implemented and we are monitoring the results.

New meetings will be synced as usual.

Meetings created between Friday 10/4 to Monday 13/4 will be synced successively. All meetings are expected to be fully synced by Wednesday night.
Posted Apr 14, 2026 - 14:23 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 14, 2026 - 09:10 CEST

Update

We are continuing to investigate this issue.
Posted Apr 14, 2026 - 08:47 CEST

Update

We are continuing to investigate this issue.
Posted Apr 13, 2026 - 11:19 CEST

Update

We are continuing to investigate this issue.
Posted Apr 13, 2026 - 11:18 CEST

Update

We are continuing to investigate this issue.
Posted Apr 13, 2026 - 11:17 CEST

Investigating

Users may experience issues with the Outlook calendar integration. Our engineers are aware of the issue and are working towards a solution.
Posted Apr 13, 2026 - 11:16 CEST
This incident affected: Upsales App and Integrations (Office 365 calendar sync).