Site availability issues
Incident Report for Upsales
Resolved
This incident has been resolved.
Posted Nov 18, 2021 - 10:22 CET
Update
We are continuing to monitor for any further issues.
Posted Nov 18, 2021 - 09:23 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2021 - 09:09 CET
Investigating
Some customers may currently be experiencing site availability issues. We’re currently working to resolve this issue.
Posted Nov 18, 2021 - 09:00 CET
This incident affected: Upsales App.