Connection problems for our internet provider
Incident Report for Upsales
Resolved
This incident has been resolved
Posted May 19, 2020 - 16:59 CEST
Monitoring
A fix has been implemented and we're monitoring the results
Posted May 19, 2020 - 15:11 CEST
Identified
The issue has been identified and our ISP is working on a fix
Posted May 19, 2020 - 14:41 CEST
This incident affected: Upsales App, System components (File service), and Integrations (Other integrations).