Degraded performance within Upsales

Incident Report for Upsales

Resolved

This incident has been resolved.
Posted Jul 24, 2025 - 17:41 CEST

Identified

We're experiencing degraded performance throughout the program, this results in some parts not loading correctly. Our developers have determined the issue and is working on solving it.
Posted Jul 24, 2025 - 13:07 CEST
This incident affected: Upsales App, Email (Mail Events, Outgoing Email), System components (Prospecting, File service, Insights), and Integrations (Other integrations).