Upsales unavailable

Incident Report for Upsales

Resolved

This incident has been resolved and Upsales is working as normal
Posted Feb 27, 2025 - 10:30 CET

Update

We are continuing to investigate this issue.
Posted Feb 27, 2025 - 10:26 CET

Investigating

Some customers may currently be having problems reaching our system. We’re currently working to resolve this issue.
Posted Feb 27, 2025 - 10:26 CET
This incident affected: Upsales App.