Performance issues
Incident Report for Upsales
Resolved
This incident has been resolved.
Posted Apr 18, 2024 - 13:00 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 18, 2024 - 09:51 CEST
Investigating
Some users may be experiencing login issues Upsales is at the moment. We are aware of the issue and are working to fix it.
Posted Apr 18, 2024 - 08:48 CEST
This incident affected: Upsales App.