Power Slowness
Incident Report for Upsales
Resolved
This incident has been resolved, we apologize for any inconvenience this may have caused
Posted Oct 06, 2020 - 17:02 CEST
Investigating
Some users may be experiencing slowness accessing parts of the site. We’re aware of the issue and are working to fix it.
Posted Oct 06, 2020 - 16:14 CEST
This incident affected: Upsales App.