Outlook calendar sync temporarily affected

Incident Report for Upsales

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 08:57 CET

Identified

Some users may notice that meetings created in Upsales are not syncing to their Outlook calendars.

We’ve identified the issue and are working on a fix.
Until it’s resolved, we recommend creating new meetings directly in your Outlook calendar. Once the issue is fixed, meetings will sync back to Upsales as normal.
Posted Oct 31, 2025 - 10:28 CET
This incident affected: Integrations (Office 365 calendar sync).