Upsales login issues
Incident Report for Upsales
Resolved
This incident has been resolved. We have added measures so this particular issue will not occur again.
Posted Feb 26, 2024 - 11:44 CET
Identified
The issue has been identified and we are doing our best to resolve the issue as soon as possible.
Posted Feb 26, 2024 - 11:19 CET
This incident affected: Upsales App.