Degraded performance in the Office 365 calendar sync

Incident Report for Upsales

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 02, 2026 - 14:43 CEST

Identified

We have identified a larger then usual queue on the Office 365 meeting syncing between the systems. All meeting will be synced in eventually but some may take longer than usual.
Posted Jun 01, 2026 - 08:42 CEST
This incident affects: Integrations (Office 365 calendar sync).