Insights are currently down or functioning inconsistently.

Incident Report for Upsales

Resolved

This incident has been resolved.
Posted Dec 25, 2024 - 12:25 CET

Identified

We’re actively working to resolve the issue and restore full functionality as soon as possible.
Posted Dec 19, 2024 - 10:17 CET
This incident affected: System components (Insights).